Discussion:
[Check_mk (english)] Check_MK service notifications not being generated
(too old to reply)
Nick Minter
2018-06-15 02:34:37 UTC
Permalink
Hi all,

I'm currently having some issues with service notifications within Check_MK.

Host notifications are working just fine and sending a custom notification
is also working but notifications are not being generated when a service
changes state.

Notifications for services are being generated in ~/var/nagios/nagios.log
but not in ~/var/check_mk/notify/nagios.log (Host notifications are
however).

I've checked the setup against
https://mathias-kettner.de/checkmk_flexible_notifications.html and the site
config appears to be correct.

Within the hosts entry the Host/Svc section is also showing no service
notifications, only Host.

Does anyone have any ideas why this might be occurring?
Paul
2018-06-15 02:46:19 UTC
Permalink
Which version are you using?
Do you have any rules (contacts) assigned to the services in question?
Are service notifications enabled?
Post by Nick Minter
Hi all,
I'm currently having some issues with service notifications within Check_MK.
Host notifications are working just fine and sending a custom notification
is also working but notifications are not being generated when a service
changes state.
Notifications for services are being generated in ~/var/nagios/nagios.log
but not in ~/var/check_mk/notify/nagios.log (Host notifications are
however).
I've checked the setup against
https://mathias-kettner.de/checkmk_flexible_notifications.html and the
site config appears to be correct.
Within the hosts entry the Host/Svc section is also showing no service
notifications, only Host.
Does anyone have any ideas why this might be occurring?
_______________________________________________
checkmk-en mailing list
Manage your subscription or unsubscribe
http://lists.mathias-kettner.de/mailman/listinfo/checkmk-en
Nick Minter
2018-06-15 05:45:22 UTC
Permalink
W
​ell that's more than a little frustrating.


I've created a rule to enable service notifications and it appears to be
working correctly again.


No idea why it stopped then, its been functioning normally for rather long
time.


Thanks for the help Paul.
Post by Paul
Which version are you using?
Do you have any rules (contacts) assigned to the services in question?
Are service notifications enabled?
Post by Nick Minter
Hi all,
I'm currently having some issues with service notifications within Check_MK.
Host notifications are working just fine and sending a custom
notification is also working but notifications are not being generated when
a service changes state.
Notifications for services are being generated in ~/var/nagios/nagios.log
but not in ~/var/check_mk/notify/nagios.log (Host notifications are
however).
I've checked the setup against https://mathias-kettner.de/
checkmk_flexible_notifications.html and the site config appears to be
correct.
Within the hosts entry the Host/Svc section is also showing no service
notifications, only Host.
Does anyone have any ideas why this might be occurring?
_______________________________________________
checkmk-en mailing list
Manage your subscription or unsubscribe
http://lists.mathias-kettner.de/mailman/listinfo/checkmk-en
Loading...